Missing fields for mapping when importing issues through CSV in Jira Server / Data Center
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When importing issues through a CSV file into Jira, on the field mapping screen, the user can't find a certain field to map because it is not shown on the drop-down list.
Example scenario

On the field mapping screen, the user can't map the field Issue Type because it is not shown on the drop-down list.
Environment
All versions of Jira Core 7.x, 8.x, 9.x, 10.x
Diagnosis
The expected field is not mapped in the Field Mapping step of CSV import.
When trying to manually create the record through Jira's "Create" button on the header, such fields are also not present in the creation screen.
Cause
A) The missing fields are not present in the respective Create Issue Screen for that issue type in that project. For information related to assigning screens to specific operations such as the Create operation please see Associating a Screen with an Issue Operation.
B) The missing field has no context for the project and/or issue type. For more information on custom field context please see our documentation Configuring Custom Field Context
C) The field is one of the banned fields for bulk create issues:
Attachment
Created
Creator
Custom Fields
Due Date
Issue key
Issue Links
Issue Type
Last Viewed
Original Estimate
Project description
Project key
Project name
Project type
Project url
Resolution
Resolved
Security Level
Status
Time Spent
Updated
Watchers
Worklog
ℹ️A and C happen only when importing using the Issues > Import Issues from CSV path. The fields should show up normally in Administration > System > External System Import > CSV.
D) If the CSV import file has two columns with the same title (this can happen for fields that accept multiple values), the importer screen will limit the fields available to only those that can accept multiple values (such as labels, affected versions, Components, etc)
Solution
A) Missing fields in create screen
Go into the respective project administration screen
Click on the project's Screen Scheme
For all affected issue types, edit their respective Create Issue Screen and add the missing fields
OR
Import the CSV using Administration > System > External System Import > CSV
B) Missing Field Context
Go to the context configuration page of the field in question
Add or edit the existing context to include the project and the issue type in question
C) Banned field
Request an admin to import the CSV or don't import those fields.
D) Duplicate columns in CSV file
You can either select a field that can accept multiple values, or alternatively, you could rename one of the columns in the CSV file before importing it in order to place that data into a different field.
Some fields may be available for mapping in the CSV import if they're present in any Create Screen in use by that Project, but their values will only be persisted by Jira if the field's present on that respective Issue Type Create Screen.
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