Missing FieldId from ChangeItem Table

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

During project import / migration / upgrade procedure, there is an error related to either

  • Existance of the extra FieldId column from ChangeItem table

  • Or Missing the FieldId column from ChangeItem table

The following appears in the atlassian-jira.log

1 2 3 4 5 6 7 8 9 [o.o.c.entity.jdbc.DatabaseUtil] Column "FIELDID" of table "changeitem" of entity "ChangeItem" exists in the database but has no corresponding field [o.o.c.entity.jdbc.DatabaseUtil] Entity "ChangeItem" has 8 fields but table "changeitem" has 9 columns.   /secure/admin/ProjectImportSelectProject.jspa[atlassian.jira.task.TaskManagerImpl] Task 'Mapping and validating import data for project 'xxxxx'.' failed. java.lang.IllegalArgumentException: [GenericEntity.set] "fieldid" is not a field of ChangeItem at org.ofbiz.core.entity.GenericEntity.set(GenericEntity.java:261) at org.ofbiz.core.entity.GenericEntity.setFields(GenericEntity.java:581) at org.ofbiz.core.entity.GenericEntity.<init>(GenericEntity.java:124)  

In case of project import, not error will be thrown in the log file or UI, JIRA will simply be redirected back to the page select page.

Diagnosis

Diagnostic Steps

Cause

This is due to this FieldId column is created by the JFS plugin. By default, there is no such FieldId Column in ChangeItem Table

  • During migration/project import, the target instance does not have this plugin enabled

  • During upgrade, the plugin is not enabled due to outdated version

Solution

Resolution

Always ensure the following:

  • When performing Project Import, ensure the source and target instance have the needed/similar plugins with each other and perform the checklist Restoring a project from backup

  • When performing Migration/Upgrade, ensure that the plugin is updated accordingly to the supported version of the newly upgraded JIRA. Also ensure the plugin list is similar from Source JIRA Instance.

Updated on April 2, 2025

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