Missing Attachment section in JIRA Issue View

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

The attachment section in the JIRA Issue View is missing.

(Auto-migrated image: description temporarily unavailable)

Cause

The com.atlassian.jira.jira-view-issue-plugin:attachmentmodule pluginkey is set to false in pluginstate table during an upgrade.

Resolution

  1. Shutdown JIRA

  2. Run the following query to identify the status of the pluginkey:

    SELECT * FROM pluginstate WHERE pluginkey = 'com.atlassian.jira.jira-view-issue-plugin:attachmentmodule';
  3. If the pluginenabled is false, set it back to true

    DELETE from pluginstate WHERE pluginkey='com.atlassian.jira.jira-view-issue-plugin:attachmentmodule';

    Warning: Backup your database before proceeding.

    This article describes how to run SQL UPDATE statements directly against the Confluence database to replace hard-coded links. UPDATE statements are not reversible — any mistake will modify your live data permanently. Before running any SQL in this article, create a full backup of your Confluence database. Test the queries in a staging environment first if possible.

  4. Restart JIRA

Updated on September 25, 2025

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