Missing Attachment section in JIRA Issue View
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
The attachment section in the JIRA Issue View is missing.

Cause
The com.atlassian.jira.jira-view-issue-plugin:attachmentmodule pluginkey is set to false in pluginstate
table during an upgrade.
Resolution
Shutdown JIRA
Run the following query to identify the status of the pluginkey:
1
SELECT * FROM pluginstate WHERE pluginkey = 'com.atlassian.jira.jira-view-issue-plugin:attachmentmodule';
If the pluginenabled is false, set it back to true
1
DELETE from pluginstate WHERE pluginkey='com.atlassian.jira.jira-view-issue-plugin:attachmentmodule';
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
Restart JIRA
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