How to Map IssueID and ParentID Fields in Jira CSV Imports
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
Unable to find the IssueID and Parent fields when importing parent-subtask relationships via CSV in External System Import.
Diagnosis
While importing CSV, it was observed that we are able to import all relations except the sub-task relation to the parent (Issue ID and parent ID fields)
The issueid or parentid fields are not suggested in the field mapping step:

Cause
Sub-tasks are turned off in the site
Sub-Tasks were turned off (disabled) when we navigate to the System> Settings> Jira Settings> Issues> Sub-Tasks.
Limitations in Jira permissions
These field are also unavailable when using the Bulk Create link found within the Issue Navigator ... Menu > Import work items from CSV
This import option is available to all Jira users that have the create issue permission for at least one project.
Solution
Enable sub-tasks
Enable the sub-tasks option while navigating to the System> Settings > Work items > Sub-Tasks (https://[yoursite].atlassian.net/secure/admin/subtasks/ManageSubTasks.jspa).
You should be able to map the Parent ID field successfully while importing after enabling the Sub-Tasks option.
Add Linked Issues field to screens
To create or edit "IssueId" and "Parent" fields, use the External System Import tool found at Settings > System > External System Import > CSV. Non-admin users can map the Issue ID and Parent fields to create new issues without needing to use External System Import.
If the Issue ID is unavailable during mapping, ensure the Linked Issues field is included on all screens to resolve this issue.
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