Mantis Attachments are corrupted upon Importing to JIRA

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Symptoms

Using the JIRA Importer Plugin to import Mantis projects to JIRA, the attachment are corrupted. By corrupted, all the attachment files are converted into a Mantis login page and this can be verified by opening the attachment on a notepad (even though the attachment is a non txt file, such as jpg, pdf, and etc).

Diagnosis

The problem generally occurs when the Mantis and its database are located on a different server than JIRA.

Cause

JIRA cannot authenticate to Mantis to retrieve its attachment.

Solution

Resolution

In order for the Mantis attachment to be imported properly, you will need to re-import Mantis again and specify the Mantis Credentials by clicking on the check-box for Mantis authentication.

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Updated on April 8, 2025

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