Long Loading Time of JIRA Cloud Dashboards

Platform Notice: Cloud and Data Center - This article applies equally to both cloud and data center platforms.

Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

  • Facing an alarming performance issue when loading a dashboard: It takes ages to load the dashboard.

  • When loading a dashboard, it takes very long time for it to be completed and any actions taken in the mean time will take a lot of time as well.

  • The activity stream takes long to load and sometimes is incomplete.

  • The following error might be displayed in the activity stream:

1 The activity source '' was slow to respond and is not included. You can try again with a longer timeout.

Cause

One of the sources used by the activity stream gadget is taking too long to respond. Most likely, this is due to the size of the source. It mostly occurs with Fisheye when you have a lot of and/or large repositories

Workaround

  1. Try to remove the activity source causing this (mainly Fisheye) from the activity stream gadget

    OR

  2. Proceed with an elimination round through the activity stream sources to identify which one is the cause for the ages load time, and disable it.

    OR

  3. Try to add/remove sources from the activity stream gadget untill you have found the one that is causing it to respond so slow, this is likely to be Fisheye

Updated on April 8, 2025

Still need help?

The Atlassian Community is here for you.