Lexorank Management Page doesn't load and receives timeout erros

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

In this article, we are going to describe a problem with Lexorank Management Page which does not load completely and we see timeout errors while browsing the page.

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Environment

Jira 9.x

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Cause

  • From thread-dump, we can find slowness with Lexorank integrity check.

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Solution

  • Creating the following index on AO_60DB71_LEXORANK should resolve this problem.

1 2 CREATE INDEX index_field_bucket_type ON AO_60DB71_LEXORANK (field_id, bucket, type);
  • Please note these important points while creating an index.

    • Remember, creating an index can help to speed up retrieval speed, but it can use more storage space in DB. The admin should consider these factors before creating an index.

    • Once the index is created, it will start improving query performance immediately. However, keep in mind that while an index speeds up data retrieval, it can slow down data insertion and updating, as the index also needs to be updated.

    • Indexing a large table will take more time than a small one, as each row in the table needs to be processed.

  • A quick workaround would be to increase AJAX timeout as mentioned in How to change the default AJAX timeout in Jira server.

Updated on April 7, 2025

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