LDAP synced user showing "User does not exist" with question mark by the user avatar
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Individual users from LDAP are showing "User does not exist" on the user profile even though the user exists in Jira and username and email are populating correctly.
Diagnosis
The user is unable to login to the Jira environment, even after performing a full sync.
The user avatar shows a question mark and by hovering over the message "User does not exist" is displayed.
Submitting a request on behalf of or adding as a request participant prompts an error to select a valid user.
There is a deleted entry in the LDAP server for this user – the user was deleted and recreated on the LDAP server.
Verify the ObjectGUID being stored for the user in the Jira database is NOT the same as the LDAP server:
1
select EXTERNAL_ID from cwd_user where user_name = '<user>';
Cause
LDAP syncronization is incorrectly mapping to the old external ID for the archived user record.
Solution
Fully remove the inactive user record with the queries in Delete user from database in Jira server and perform a full sync.
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
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