Layout broken in JIRA after upgrade
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
JIRA layout is broken after an upgrade. There is no error message on the logs. The following appears on the screen:

Cause
This issue is caused by version incompatibility between JIRA and third-party plugins. We identified this issue with the plugin JIRA Component Watcher, but it can occur with other plugins too.
Resolution
This issue can be fixed by either of the bellow options:
Remove the incompatible plugin:
Shutdown JIRA
Remove the JAR file of the plugin from $JIRA_Home/plugins/installed-plugins
Restart JIRA
Update the plugin to a compatible version:
Download the compatible version of the plugin from Atlassian Marketplace;
Replace the original JAR file of the plugin by the new version into $JIRA_Home/plugins/installed-plugins
Restart JIRA.
Was this helpful?