Knowledge Base searches still use the old Application Link URL on the Customer Portal

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After changing the URL of the Confluence Application Link, the knowledge base links on Jira Service Management still points to the old URL. We're tracking this a bug on JSDSERVER-641 - Links for Knowledge Base on JSD don't update the URL when the Application Link URL changes.

Diagnosis

Simply run the following SQL query in Jira's database to verify which is the URL in use by JSD:

1 SELECT * FROM "AO_54307E_CONFLUENCEKB";

Resolution

Always backup Jira before modifying its database.

  1. Stop Jira;

  2. Update the AO_54307E_CONFLUENCEKB table, and update the application link URL.

  3. Restart Jira;

For example, if updating the URL from HTTP to HTTPS, the following can be used:

update"AO_54307E_CONFLUENCEKB"set"APPLINK_URL"= replace("APPLINK_URL", 'http', 'https'), "SPACE_URL"= REPLACE("SPACE_URL", 'http', 'https');

This was created using PostgreSQL - if you're using a different DBMS you may need to update the query accordingly.

Updated on April 8, 2025

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