JSM Linked Issue Creation Fails to Auto-Link

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

In a Jira or JSM ticket, when creating a new JSM via the "Create Linked Issues" button, the newly created ticket is not auto-linked to the source issue

Diagnosis

  • The new issue is created successfully, however, the issue is not linked back to the source ticket from which the issue was created (Link Issue > Created Linked issue option)

  • Creating a new JSW ticket from another JSW ticket works as expected and the newly created ticket is linked back. The JSM ticket is not linked back after the creation.

  • This behaviour might also be seen only with specific JSM request types.

Cause

  • To ensure issue linking works as expected, we need to ensure all checks in the following KB article are met: Cannot link Jira issues in one or more projects

  • However, in Jira Service Management (JSM) projects, there is a configuration to add fields to the "Request type field" as well: Customize the fields of a request type. If the "Linked issues" field is missing in the request type field configuration, then this behaviour is seen.

Solution

Ensure to add the "Linked Issues" field to the request type field configuration as mentioned in the documentation here: Customize the fields of a request type

Updated on March 7, 2025

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