JSM Chat Assist Cloud sends message to requester in App home thread even when "Send message when request is raised" set to OFF.

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Assist bot still sends an automated messages to the requester threads when the toggle "Send message when request is raised" is set to OFF. To find this setting navigate to your project > channels > Chat.

Cause

On the JSM Chat settings page, you can toggle settings for "Send message when request is raised." This setting does not apply to tickets raised in places other than the request channel (i.e. Slack app home, slash command, and Jira portal).

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Solution

Expect that any tickets raised outside of the Slack request channel will not follow the toggles set in Chat settings. For tickets raised outside of the request channel, Assist will still send the message "Hi @requester, your request was raised. Go to @Assist to learn more."

There is a Feature Request for Chat settings to be respected no matter where the ticket is raised: JSDCLOUD-14775

Updated on April 11, 2025

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