JQL WAS Operator Returns Error due to Value does not Exist for Field
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
When searching for issues using JIRA Query Language (JQL) as in Advanced Searching, the was operator may return an error similar to the one below.
The error "The value 'administrator' does not exist for the field 'assignee'." (this example) indicates that administrator is not a valid value for the field assignee. The error here is thrown in the interface, and not is not logged in JIRA.

ℹ️(Note: This operator can be used with the Assignee, Fix Version, Priority, Reporter, Resolution and Status fields only.)
Cause
This can error can be caused by a few things:
Misconfigured settings in 'General Configuration'
Could be related to the following bugs
It could also be that there truly is no user named 'administrator'
Workaround
Please navigate to Administration > General Configuration and verify that the below options are enabled, if not please enable them and try searching again
User Searching By Full Name (JIRA 4.0.x - 4.4.x only)
User email visibility
JQL Auto-complete
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