JQL Search returns two same custom field options whereas there is only one in the database and on custom fields page

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Problem

While performing a JQL search for a specific custom field, it returns more than one option whereas there is only one record in the database. There is no error in the logs.

Diagnosis

  • Run the query below and ensure that there is only one record for the custom field or for each context of the custom field:

    1 select * from customfieldoption where customfield=(select id from customfield where cfname='YOUR CUSTOM FIELD NAME');
  • We can accept the data in the database as consistent if the query above returns only a single option for each field/context.

Cause

In a specific scenario, there is another record in the cache and the root cause of how this record stayed/appeared in the cache is still not known.

Solution

Workaround

Update the related field option on UI and rename it twice (from original to another name and then from another name to its original name) to update the cached data.

Updated on April 2, 2025

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