JQL search fails with the error "The option 'XXXX' for field 'XXXX' does not exist" in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

JQL search by a custom field value (e.g. "Custom user picker" = jdoe) fails with the error "The option 'XXXX' for field 'XXXX' does not exist".

Diagnosis

Navigate to Jira Administration > Issues > Custom fields and check for the presence of two custom fields with the same name.

Alternatively, you can use the SQL query below to determine if there are duplicate custom fields.

1 SELECT * FROM customfield WHERE LOWER(cfname) = LOWER('<custom field name>');

Please replace <custom field name> with the actual name of the custom field.

Cause

There are two distinct fields with identical names (even if they may differ in letter case), resulting in Jira executing the search for the unintended field.

Solution

Option 1

Use the cf[xxxx] format instead of the field name in the Advanced JQL.

Option 2

Rename one of the fields to a unique name. Compared to the first option, this approach has the advantage of preventing confusion among users who may not be familiar with this issue or the cf[xxxx] workaround.

Updated on March 24, 2025

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