Resolve JQL 'Field Not Searchable' Error in Jira Data Center

Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When executing a JQL (Jira Query Language) on Jira using fields as conditions, the following error is displayed:

Error message Field 'Birthday' is not searchable, it is only sortable.
Field '<fieldname>' is not searchable, it is only sortable.

Diagnosis

The field displayed in the error does not have a "Search Template" associated with it.

Verify this using the following steps:

  • Navigate to Administration (⚙ icon) > Issues > Custom fields

  • Find the field in the list and select Edit Details from the Actions (...) menu

  • Check the entry for the Search Template

Edit details for the custom field Birthday, the Search Template is marked with a red rectangle and has the value NONE

Cause

JQLs need the Search Template to bring results based on field values.

Solution

  • Navigate to Administration (⚙ icon) > Issues > Custom fields

  • Find the field in the list and select Edit Details from the Actions (...) menu

  • Choose an available Search Template for the related field from the drop-down list

  • Click on Update

ℹ️ A re-index might be required to bring accurate JQL results using the field above.

Updated on April 28, 2025

Still need help?

The Atlassian Community is here for you.