JIRA Upgrade Fails with 'NullPointerException' Due to Missing Name Field

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The following error messages are reported in the JIRA log file:

java.lang.NullPointerException at com.atlassian.jira.upgrade.tasks.UpgradeTask_Build602.migrateGroups(UpgradeTask_Build602.java:535) at com.atlassian.jira.upgrade.tasks.UpgradeTask_Build602.doUpgrade(UpgradeTask_Build602.java:93) at com.atlassian.jira.upgrade.UpgradeManagerImpl.doUpgradeTaskSucess(UpgradeManagerImpl.java:578) at com.atlassian.jira.upgrade.UpgradeManagerImpl.runUpgradeTasks(UpgradeManagerImpl.java:482) ...

Cause

There is a user group missing "name" field in JIRA, which breaks group migration to JIRA 4.3+ version.

Workaround

  1. Back up JIRA your original JIRA instance (the one before the upgade)

  2. Shutdown JIRA

  3. Run the below SQL query against your original JIRA's database:

    update groupbase set groupname='DATA-FIX' where groupname is null
  4. Reboot JIRA instance

  5. Locate 'DATA-FIX' group in JIRA, delete or rename it.

  6. Generate a new backup XML file

  7. Redo the upgrade with the new backup file.

Resolution

Track the resolution at JRA-24172.

Updated on April 8, 2025

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