JIRA Throws NullPointerException When Navigate To Project's Issue Types Tab
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
Multiple Issue Types Scheme are set as the default instead of only Default Issue Type Scheme.
The following appears in the atlassian-jira.log
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jadmin 922x258x1 ws5lk 127.0.0.1 /plugins/servlet/project-config/ATL/summary [jira.projectconfig.contextproviders.SummaryContextProvider] Unable to load project summary panel
java.lang.NullPointerException
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForConfigScheme(IssueTypeSchemeManagerImpl.java:276)
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForProject(IssueTypeSchemeManagerImpl.java:247)
at com.atlassian.jira.issue.fields.config.manager.IssueTypeSchemeManagerImpl.getIssueTypesForProject(IssueTypeSchemeManagerImpl.java:252)
Diagnosis
Check if there any entry that is associated to non-existing project by running the following SQL on JIRA's database:
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select * from configurationcontext where project not in (select id from project);
Check if there is a default configuration on the database:
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select * from configurationcontext where id = 10000 and fieldconfigscheme = 10000 and customfield = 'issuetype' and projectcategory is null and project is null;
Cause
There is Issue Types Scheme(s) that is associated with project(s) that no longer exist. This could be related to JRASERVER-29446 - A NullPointerException is thrown when the user navigates to the Issue Type Tab for a Project.
Resolution
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
If any records are found with the first SQL query in the Diagnosis section, remove the record with the following:
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delete from configurationcontext where project not in (select id from project);
If no records are found with the second SQL query of the Diagnosis section, please add the following:
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insert into configurationcontext values (10000, null, null, 'issuetype', 10000);
Restart JIRA
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