Jira throws Internal Server Error when trying to Manage Boards
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
When trying to view the 'Manage Boards' page, an error will pop up in the UI, stating 'Internal Server Error'. The list of boards are not visible.
The following appears in the atlassian-greenhopper.log
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java.lang.reflect.UndeclaredThrowableException
at com.sun.proxy.$Proxy2588.findRapidViewsByName(Unknown Source)
at com.atlassian.greenhopper.web.rapid.view.RapidViewListHelper.buildListAndConfigModel(RapidViewListHelper.java:87)
at com.atlassian.greenhopper.web.rapid.view.RapidViewListResource$2.call(RapidViewListResource.java:82)
at com.atlassian.greenhopper.web.rapid.view.RapidViewListResource$2.call(RapidViewListResource.java:78)
at com.atlassian.greenhopper.web.util.RestCall.response(RestCall.java:42)
at com.atlassian.greenhopper.web.AbstractResource.createResponse(AbstractResource.java:100)
Diagnosis
To check whether or not the instance is facing the same problem that we are facing here, perform the following query :
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select * from AO_60DB71_RAPIDVIEW
From the results, check if there are any entries that either does not have any values for the 'SAVED_FILTER_ID' column, or if the value is 0.
Cause
The value of the 'SAVED_FILTER_ID' is invalid (NULL or 0). As an Agile board needs to be based on a filter to retrieve information, when the filter that it is configured to use is invalid, problems arise.
Solution
Resolution
Perform the following SQL query :
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select * from AO_60DB71_RAPIDVIEW
Check to see if there are any invalid values in the 'SAVED_FILTER_ID' column
Delete the entries from the AO_60DB71_RAPIDVIEW where the 'SAVED_FILTER_ID' has an invalid value
Restart the instance
Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.
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