JIRA throws HTTP Status 500 Error with GeneralRuntimeException Could not determine database type
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Problem
When starting JIRA, possibly after an unexpected network outage, you may encounter an Internal Server Error with a 500 HTTP Status code.
The following message appears in the browser:
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HTTP Status 500 - org.ofbiz.core.util.GeneralRuntimeException: Could not determine database type. (Communications link failure The last packet sent successfully to the server was 0 milliseconds ago. The driver has not received any packets from the server.)
Below error appears on your browser:

If using a PostgreSQL database server you'll see the following error message:

Cause
This error message could be caused by a problem connecting JIRA to its database. For example, if you experienced a power outage where your database server was shut-down, it may not have been successfully restarted after power was restored.
Resolution
Check the status of your database server to ensure it is running.
Check if the database related Service is started and running.
If your database server is running, check your network configuration to ensure that it is accessible by JIRA
Use ping from the JIRA server to the database server
Use telnet or nc (Netcat) from the JIRA server to the database server for testing port connectivity
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