Jira system events missing from the UI
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
System events such as "Issue Archived" or "Issue restored" are missing from Jira's menu Administration

> System > Events or from webhooks listening configuration Administration

> System > Webhooks
Environment
Jira Software Data Center 9.4.x
Diagnosis
The following query will identify if there are duplicate entries that have the same name
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select name , count(*)
from jiraeventtype
group by name
HAVING COUNT(*) > 1 ;
Cause
If an entry was imported / added to the jiraeventtype table with the same name as a system event (system events have the value "jira.system.event.type" in the column event_type) a race condition will happen while retreiving the values and since Jira controls and expects a single unique name for each row , it will fail to display one of the entries making it hiding the system event most of the cases.
Solution
Database updates are not supported and can result in integrity issues. Please ensure to test this before applying to production.
Restore the table sanity and have unique names for the events leaving the original system event names intact. From the previous query update the entries that are duplicate , for example if the "Issue Restored" appears more then once fix it using the query below.
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update jiraeventtype
set name='Custom Issue Restored'
where name = 'Issue Restored' and event_type is null;
Restart Jira
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