Jira Stops working after Disabling or Uninstalling Jira Service Management

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

After disabling or uninstalling Jira Service Management Jira stops working. Symptoms include:

  • It is not possible to log in but through login.jsp;

  • Jira's dashboards stop working and might show the error "An internal server error occurred when requesting resource."

  • Accessing a project is not possible or project screens are blank;

  • Trying to view the Permission tab through the project created throws an error.

The following appears when trying to log in:

1 2 3 4 java.lang.NullPointerException at com.atlassian.jira.permission.DefaultPermissionSchemeManager.hasSchemePermission(DefaultPermissionSchemeManager.java:499) at com.atlassian.jira.permission.DefaultPermissionSchemeManager.hasPermission(DefaultPermissionSchemeManager.java:467) at com.atlassian.jira.permission.DefaultPermissionSchemeManager.hasSchemeAuthority(DefaultPermissionSchemeManager.java:393)

These are thrown in the logs:

1 2 3 4 5 2014-02-14 14:21:39,898 http-bio-8443-exec-3 ERROR xxxxx [500ErrorPage.jsp] Exception caught in 500 page java.lang.NullPointerException java.lang.RuntimeException: java.lang.NullPointerException at com.atlassian.jira.dashboard.permission.JiraGadgetPermissionManager.hasProjectsPermission(JiraGadgetPermissionManager.java:165) at com.atlassian.jira.dashboard.permission.JiraGadgetPermissionManager.voteOn(JiraGadgetPermissionManager.java:148) at com.atlassian.jira.dashboard.permission.JiraGadgetPermissionManager.filterGadgets(JiraGadgetPermissionManager.java:71)
1 2 3 4 5 2014-02-14 14:37:39,773 http-bio-8080-exec-1 ERROR matheus 877x158x5 1fqd1vy 192.168.10.104 /rest/gadget/1.0/issueTable/jql [common.error.jersey.ThrowableExceptionMapper] Uncaught exception thrown by REST service java.lang.NullPointerException at com.atlassian.jira.issue.search.parameters.lucene.DefaultPermissionQueryFactory.collectProjectTerms(DefaultPermissionQueryFactory.java:171) at com.atlassian.jira.issue.search.parameters.lucene.DefaultPermissionQueryFactory.getQuery(DefaultPermissionQueryFactory.java:68) at com.atlassian.jira.issue.search.parameters.lucene.PermissionsFilterGeneratorImpl.getQuery(PermissionsFilterGeneratorImpl.java:38)

Cause

This seems to be happening because Jira Service Management does not remove or hide the Service Management Customer - Portal Access (Anyone) permission. Once Jira tries to load this information, the errors above are displayed. This is a bug, which is being tracked on JRASERVER-36940 - JIRA search broken after disabling Service Desk.

Workaround

Option 1:

  • Reinstall or re-enable Jira Service Management.

  • If a license incompatibility caused Service Management to be disabled, you will need to proceed to the steps in option 2.

Option 2:

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  1. Shutdown Jira.

  2. Execute the following SQL query to delete the 'Service Management Customer - Portal Access (Anyone)' permission from the database:

    1 DELETE FROM schemepermissions WHERE perm_type = 'sd.customer.portal.only';
  3. Start Jira.

Updated on April 8, 2025

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