Jira stopped writing to some log files after upgrade
Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
This article helps you resolve an issue where the atlassian-jira.log file is not being written to after upgrading Jira, even though other logs are updating as expected. This happens when you have encrypted passwords in server.xml configured.
Environment
Jira Data Center version 10.3.x
Diagnosis
Standard troubleshooting steps such as verifying permissions, disk space, log4j2.xml configuration, and plugin isolation may not resolve the problem. This bug is also ruled out: https://jira.atlassian.com/browse/JRASERVER-78637
Cause
This issue can occur if the required log4j JAR files are missing or not correctly located in the <jira-install>/atlassian-jira/WEB-INF/lib directory after an upgrade.
Solution
If your atlassian-jira.log file is not being updated after upgrading to Jira Data Center 10.3.x, follow these steps:
Stop Jira Shut down your Jira instance gracefully before making any file changes.
Copy the log4j JAR files to the correct directory Locate the following files in <jira-install>/lib:
log4j-api-2.20.0.jarlog4j-1.2-api-2.20.0.jarlog4j-core-2.20.0.jarlog4j-slf4j2-impl-2.20.0.jar
Copy all these files into <jira-install>/atlassian-jira/WEB-INF/lib.
Start Jira
Verify logging
Check that atlassian-jira.log and other expected log files are now being written to in <JIRA_HOME>/log.
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