Jira Software Data Center: On changing the columns for a board the Error "Status XXXX repeated in status mappings" shows up
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
When changing the columns (adding/moving a status, adding/removing a column) of a board you get the error
"Status XXXX repeated in status mappings"

Environment
Jira Software 8.x , 9.x
Diagnosis
When checking the atlassian-greenhopper.log file you will find a correlating error:
1
2
2024-05-31 15:36:02,023 http-nio-49127-exec-9 url: /j9127/rest/greenhopper/1.0/rapidviewconfig/columns; user: admin INFO admin 936x94x1 21kyb7 0:0:0:0:0:0:0:1 /rest/greenhopper/1.0/rapidviewconfig/columns [web.rapid.view.RapidViewEditResource] GreenHopper REST method failed with SC = 400 - JiraCopiedBadRequestWebException
2024-05-31 15:36:02,023 http-nio-49127-exec-9 url: /j9127/rest/greenhopper/1.0/rapidviewconfig/columns; user: admin INFO admin 936x94x1 21kyb7 0:0:0:0:0:0:0:1 /rest/greenhopper/1.0/rapidviewconfig/columns [web.rapid.view.RapidViewEditResource] JiraCopiedRestErrorCollection[errorMessages=[],errors={column.3.name=Status "Estimation" repeated in status mappings, column.5.name=Status "Blocked" repeated in status mappings}]
Cause
The root cause for this is unknown, but most likely due to an issue during a project import. The board configuration tables will have the status mentioned in the error message in more than one column.
Solution
In the board configuration find the status with the error in any column and drag it to the Unmapped Status Column.
Repeat this for every status in the displayed error messages. For the example from the screenshot above this will need to be done for the statuses Blocked and Estimation.
You will receive error messages on these actions as well until all duplicated Statuses have been removed.
After the error message is cleared you can change the columns further without errors.
Still having problems?
Contact Atlassian Support. We'll be happy to advise you. Please include as much detail as possible, where applicable:
Logs from the affected application (if applicable)
Screenshots of the error message (if they're not covered in logs)
Information about the steps you've taken previously
Was this helpful?