Jira Software Data Center Kanban board does not show all issues

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

Some issues are not displayed on a Kanban Board even though they are displayed in the filter that is being used in the board when viewed directly in the Issue Navigator. This knowledge article lists all the known causes for this type of issue.

Solution

1 - Sub Filter based on a hidden Fix Version field

By default, all Kanban boards have the following sub-filter, which filters issues based on the Fix Version field:

fixVersion in unreleasedVersions() OR fixVersion is EMPTY

If the Fix Version field is hidden for a specific issue type or project, issues of that type won't appear in search results. Learn more about Hiding or Showing a Field. As a result, when using the filter above, since the fixVersion "does not exist" for that issue type, the filter will filter out issues of that type.

Diagnosis

  1. Go to the Kanban board's Configuration by selecting Board > Configure

  2. Go to the General menu within the board configuration, and check if the Kanban board sub-filter is being used

  3. Combine the board Filter Query and the Kanban-based sub-filter query by using the following formula (make sure to remove any ORDER BY from either query, and to add parentheses around each query):

    (board filter query) AND (Kanban-based sub-filter)
  4. Go to the issue search page, switch to the advanced mode, and paste the full query

  5. If the issues missing from the Kanban board are missing from the combined JQL (Jira Query Language) queries, use the next steps to solve this

Workaround

  • If the fixVersion field is hidden and causing issues, you can::

    • Either delete the Kanban board sub-filter so that it stops filtering out issues based on the fixVersion field. You can do it by simply deleting the content of the field Kanban board sub-filter in the Board General Configuration page

    • Or make the field available for the project as described in Hiding or showing a field and re-index Jira.

  • If the problem is happening due to other search criteria, adjust the Kanban board sub-filter so it won't filter out those issues.

2 - Epics belonging to a project outside the scope of the board

Issues linked to Epics outside the board's scope won't appear if Swimlanes are based on Epics. See also bug JSWSERVER-11318 - Stories from external epics disappear in swimlanes.

Diagnosis

  1. Check if the missing issue is linked to an Epic ticket.

    1. If that's the case, take note of the Project the Epic belongs too

  2. Navigate to the Configuration of the Kanban board by opening the board and then clicking on Board > Configure

    1. Go to the Swimlanes menu within the board configuration, and check if the setting Base Swimlanes on is set to Epics

    2. Go to the General menu within the board configuration, and check the list of Projects in Board

  3. If the project the Epic belongs to is not listed there, use the next steps to solve this

Workaround

Please use one of the following options:

  • Add the project that the Epic belongs to, to the project listed in the Board (by editing the Filter query associated to the board)

  • Or change the Swimlanes configuration, so that swimlanes are not based on Epics

3 - Only Epics missing on the board

If your Kanban board is missing Epics only, you may have the "Epics Panel" setting enabled (Board Configuration > Columns). As explained in Scenario 2-1 ofExplaining how Epics are displayed when using Kanban boards, when this option is enabled, Epics will appear as a panelin the Kanban Backlog page (regardless of whether they're in the Backlog status or not) rather than as cards in the board.

Diagnosis

  1. Navigate to the Configuration of the Kanban board by opening the board and then clicking on Board > Configure > Columns.

  2. Check if the "Epics panel" setting is enabled.

Workaround

  • Turn off the "Epics panel" toggle in the Board configuration > Columns page, if you want to visualize Epics as Cards.

4 - Issue Workflow status not mapped to Column

If an issue workflow status is not appear or mapped in the Kanban board columns (Board Configuration > Columns), the issue will not shown in the kanban board view although the issue appear in the search results.

Diagnosis

  1. Identify the missing issue workflow status.

  2. Navigate to the Configuration of the Kanban board by opening the board and then clicking on Board > Configure > Columns.

  3. Check if the issue workflow status appears or mapped in the Kanban columns.

  4. Check if the issue type of the workflow status are mapped correctly in the Project workflow on Project settings > Workflows > look for the issue type workflow.

Workaround

Updated on May 22, 2025

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