Jira Service Management queue is blank

Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.

Summary

Problem

The Queues section in Service Management is accessible but doesn't load any content. It appears empty as the image:

(Auto-migrated image: description temporarily unavailable)

Diagnosis

Browsing the section with another Browser (or in Chrome Incognito mode or IE InPrivate mode) the page loads normally.

Cause

The cached content in the browser is broken.

Solution

Resolution

Clear your web browser cache. Instructions for every browser at How do I clear my web browser's cache, cookies, and history?

Updated on April 2, 2025

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