Jira Service Management Cloud project displays unwanted customers
Platform Notice: Cloud Only - This article only applies to Atlassian products on the cloud platform.
Summary
You notice there are some unwanted Jira Service Management customers displayed in the "Customer" section (Service project > Under Channels & People > Customers).
Diagnosis
Unwanted customers/users are listed under the Customers page of a service project. In some cases, these users are internal users (ie. Users with/without a Jira license) that you don't want to be part of the current Service project.
Cause
This behavior occurs when the Browse Projects permission is granted to one of the groups that they are part of. Users with this permission are considered customers by Jira Service Management and are listed on the Customer section in the Service project.
For instance: If user A (unlicensed Jira Service Management user) is part of the "Developers" group and granted Browse projects permission in the Service project, then user A and other users who are in the Developers group will be considered Jira Service Management Customers and will be listed in the Customer section.
Solution
You need to remove the specific group that the affected users are part of from the Browse project permission of the Service project. Follow the below steps to proceed:
Navigate to Service Project > Project settings > Access > Project Permissions.
Click on Actions > Edit permission.
Find Browse project permission.
Select Remove > Choose the desired group to be removed > Remove the group.
This will remove the Browse project permission from the chosen group. Please keep in mind that removing this permission will nullify the ability of this group of users to see issues on this project.
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