Jira Service Management mail handler creating empty comments

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When using Outlook some comments created by the mail handler are empty

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Environment

Jira Service Management 4.22.2 or higher (could impact earlier versions)

Diagnosis

Inspecting the e-mail that generated the empty comment we can see it is a forwarded e-mail to the Email channel account.

Checking Jira Service Management Email requests setting under Administration > Application > Jira Service Management > Email requests we can see 'Strip quotes' is enabled:

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Cause

This is working as designed. When 'Strip quotes' is enabled the forwarded message should not be included on the comment.

To avoid the empty comment you can use the 'Don't strip quotes' option.

Note: Gmail works differently, and this is being tracked on bug JSDSERVER-12016

Updated on April 8, 2025

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