Jira Service Management Login-Free portal not working
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Starting with Jira Service Management 5.3, as documented in JSDSERVER-5227 - Make the Login-Free portal available on JSM Data Center, it is possible to have a Login-Free portal, so customers don't have to log in to see the portal and its request types.
However, in some circumstances the login-free portal might not work and the user still be requested to log in.
Environment
Jira Service Management >= 5.3
Login-free setting enabled in Cog > Applications > Login-free portal
Diagnosis
When attempting to view the portal, customers are still presented with a login page.
Cause
By going to the Dark Features page, as instructed on How to manage dark features in Jira, the following Dark Feature is enabled:
public.access.disabled
This feature flag is provided on How to control anonymous user access in a public Jira instance, and will also affect the Login-Free portal by preventing it from being enabled, given that the Dark Feature is intended to lock down the instance and prevent anonymous access. Even though it's working as expected, a feature request to notify the administrators that the login-free will not work correctly if that flag is enabled, has been created:
Solution
Remove the dark feature above, or accept that the login-free portal will not work as the system is restricting any anonymous access as it is configured to.
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