Jira Service Management Customer Portal is slow for customers

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The Customer Portal loads fast for all Jira licenced users (Agents), but loads slowly for all Customers. 

Environment

JSM 5.12.4

Diagnosis

In the browser's network trace (Generating HAR files and analyzing web requests), the request /rest/servicedesk/1/customer/models for customer accounts are slow (~4 seconds):

HAR from customer accounts

In comparison, the request /rest/servicedesk/1/customer/models for agent accounts are much quicker (~0.4 seconds):

(Auto-migrated image: description temporarily unavailable)

If the customer account is elevated to an agent account, then the customer portal loads fast for the same account. 

Cause

The permission checks for customer accounts can't be bypassed, which become slow when the number of customer portals is high (~2000 customer portals). 

Solution

Upgrade to JSM 10.3.2+ and apply the dark feature (How to manage dark features in Jira Server and Data Center): 

  • sd.use.global.cache.for.permission.check.enabled

An improvement has been made after JSM 10.3.2+ where the cache for permission checks can be made more effective with the dark feature. 

Updated on March 7, 2025

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