Jira Service Fails To Start in Windows - Is Not a Valid Win32 Application

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

Jira Service fails to start in Windows with the following error in the Windows event log:

1 Event ID 7000 and "%1 Is Not a Valid Win32 Application"

The following appears in commons-daemon.log for Apache Tomcat:

1 2 3 4 5 6 7 8 9 [2012-11-24 13:37:25] [info] Running 'jira' Service... [2012-11-24 13:37:25] [info] Starting service... [2012-11-24 13:37:25] [error] %1 is not a valid Win32 application. [2012-11-24 13:37:25] [error] Failed creating java C:\Progra~2\Java\jdk1.6.0_24\jre\bin\server\jvm.dll [2012-11-24 13:37:25] [error] %1 is not a valid Win32 application. [2012-11-24 13:37:25] [error] ServiceStart returned 1 [2012-11-24 13:37:25] [error] %1 is not a valid Win32 application. [2012-11-24 13:37:25] [info] Run service finished. [2012-11-24 13:37:25] [info] Commons Daemon procrun finished

Cause

There are a number of known causes for this problem:

  1. Windows has issues with services that have spaces in the file path as described in this Microsoft article. The root cause of this issue can be due to the Jira service using the JRE/JDK that is installed in the system rather than the bundled JRE that came along with the Standalone Installer for Windows. And the installed JRE usually has a space in the path as it is usually at the location "C:\Program Files (x86)\Java" or "C:\Program Files\Java".

  2. Jira has been installed in a 64-bit Windows version using the 64-bit installer, however is using 32-bit Java.

  3. Jira has been installed in a 64-bit Windows version using the 32-bit installer, however is using 64-bit Java.

When installing Jira onto a 64-bit Windows, we recommend using the 64-bit installer and bundled JRE as using 32-bit on 64-bit architecture is known to cause problems as in our JIRA crashes when running as a Windows Service KB article.

Workaround

Try to start Jira using the start-jira.bat file in Jira's bin directory to restore access until the Windows Service is fixed.

ℹ️ Remember to transfer the JVM arguments from the service to setenv.bat. More details about it on Setting properties and options on startup.

If this doesn't work, it could be due to the %JAVA_HOME% variable pointing to the incorrect JVM as well.

Resolution

  1. Verify that Jira is using the correct JVM by editing the service, as in our Setting Properties and Options on Startup documentation. If the bundled installer was used, the JVM should be the following:

    1 C:\Program Files\Atlassian\JIRA\jre\bin\server\jvm.dll

    ℹ️ This may be in Program Files (x86) if using Windows 64-bit and Jira 32-bit. If this is how your Jira is configured, we recommend migrating to 64-bit Jira on 64-bit Windows.

  2. Start Jira using the Service.

  3. If this does not resolve the problem, delete the %JAVA_HOME% environment variable, as set in our Installing Java docs.

  4. Take note of the JVM configurations by following Setting Properties and Options on Startup.

  5. Reinstall the service with the following, executing on the command line in <JIRA_INSTALL>/bin:

    1 2 service.bat remove service.bat install
  6. Restore the service configurations.

  7. Attempt to start the application.

"There has been some report as "tomcat8w.exe.x64" is being removed after the upgrade process from under the bin folder so you need to install the 64-bit tomcat and place it under the bin folder for the "atlassian-jira-software.x.x.x\bin"."

Updated on April 8, 2025

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