Jira Service Desk Portal URL is being automatically redirected

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When users are trying to access Jira Service Desk Portal URL, it gets automatically redirected to another URL, ending to a 404 - Dead Link error.

Environment

Jira Server / Data Center

Diagnosis

Although it's possible to change the Portal URL as outlined in this KB: Configure custom URL for the Jira Service Management customer portal, Jira by design also does redirect the Service Desk Portal when accessing it directly from a private window for example:( it does add a line destination=portal%2F1 in the URL.)

Expected:

  • FROM : https://JIRA_BASE_URL/servicedesk/customer/portal/

  • TO       : https://JIRA_BASE_URL/servicedesk/customer/portal/destination=portal%2F1

However, some plugins can change the destination=* and head to a unknown URL, causing a 404 - dead link, since the page does not exists in Jira, like in the example below:

Not expected:

  • FROM : https://JIRA_BASE_URL/servicedesk/customer/portal/destination=portal%2F1

  • TO      : https://JIRA_BASE_URL/servicedesk/customer/portal/destination=https://JIRA_BASE_URL/plugins/servlet/desk

Cause

Due to this, some 3rd party plugins are well known to cause this issue. If you have some of these plugins installed on your instance, it could be potentially cause the URL Portal redirect:

Solution

  • Either disable the plugin by navigating to Jira Administration > Manage apps > Manage apps or;

  • Contact the vendor of the plugin to get help, as third-party plugins fall out of our scope as per our support offerings and, therefore, since the plugins can interact in many way with Jira's code, we don't have the necessary expertise to help on this.

Updated on March 10, 2025

Still need help?

The Atlassian Community is here for you.