Jira Service Desk Hidden fields with present values not working with Insight Custom fields
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
You have a Service Desk project which has custom Request types.
One specific Assets custom field is hidden and another Assets custom field should have different values depending on which request type is selected.
However, you are unable to do item (2) because it always map to the same default values regardless of the Request Type selected on the Customer Portal.
Diagnosis
Goal: Customers via Customer Portal can only select the Support Products objects depending on the Request Type selected.
Example
Assets Objects


Assets custom fields

Assets custom fields configuration


Project settings > Request Types

Hidden fields with preset values


Result
Regardless of the Request Type selected on the Customer Portal, Hidden fields are not being taking into consideration and the most recently defined present values are displayed on Support Products custom field.


Cause
To access hidden preset values, you need to use the Assets Referenced Object instead of Assets Object/s since the latter cannot access hidden values.
Resolution
The way to resolve this would be to create Assets Referenced Object for the Support Product custom field in case of this example.
Create an Assets Referenced Object
For this example, configuration could be something like this:

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