Jira Server or Data Center throws "Searcher not available at this moment" exception when querying users

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

User-related actions in Jira fail and "Searcher not available at this moment" is printed to the atlassian-jira.log file.

Environment

Jira 7.2 or later.

Diagnosis

Jira UI

Some user picker and suggestion components return an error message or status 500. For example, the issue navigator and user picker custom field dropdowns may fail to load.

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Logs

In the <jira-local-home>/log/atlassian-jira.log file:

1 2 3 4 5 java.lang.RuntimeException: Searcher not available at this moment at com.atlassian.jira.bc.user.search.DirectoryUserIndexer.lambda$internalSearch$6(DirectoryUserIndexer.java:243) at java.base/java.util.Optional.orElseThrow(Optional.java:408) at com.atlassian.jira.bc.user.search.DirectoryUserIndexer.internalSearch(DirectoryUserIndexer.java:243) at com.atlassian.jira.bc.user.search.DirectoryUserIndexer.search(DirectoryUserIndexer.java:228)

Cause

Jira maintains an index of directories, users, groups, and group memberships to expedite searches. Unlike the search index, this index is built at startup and whenever significant directory-related changes are performed. This index does not survive restarts.

You can witness this index being built at startup with this line:

1 2024-04-19 14:00:00,000-0000 main INFO [c.a.j.c.embedded.ofbiz.IndexedUserDao] Reindex all users took: 80.00 ms

If another environmental issue breaks this index, components that query users will throw "Searcher not available at this moment" exceptions.

Root Cause 1

The database or file system were previously inaccessible. Root cause analysis requires application log review to identify the underlying problem.

Root Cause 2

Jira's search index was missing or invalid during startup. This prevented some core services, including the user index, from initializing.

Solution

Once any root cause errors have been addressed, you must force Jira to rebuild the user index.

Completely restarting the application will reset and rebuild the index. On a Data Center cluster, a rolling restart is sufficient.

Updated on April 15, 2025

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