Searcher not available in Jira Data Center user queries and project creation
Platform Notice: Data Center Only - This article only applies to Atlassian apps on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Learn how to fix the error "Searcher not available at this moment" when attempting user-related actions or creating projects in Jira.
Environment
Jira 7.2 or later.
Diagnosis
Issue 1: User picker issue on Jira UI
Some user picker and suggestion components return an error message or status 500. For example, the issue navigator and user picker custom field dropdowns may fail to load.

Issue 2: Project creation fails in Jira UI
Logs
In the <jira-local-home>/log/atlassian-jira.log
file:
java.lang.RuntimeException: Searcher not available at this moment
at com.atlassian.jira.bc.user.search.DirectoryUserIndexer.lambda$internalSearch$6(DirectoryUserIndexer.java:243)
at java.base/java.util.Optional.orElseThrow(Optional.java:408)
at com.atlassian.jira.bc.user.search.DirectoryUserIndexer.internalSearch(DirectoryUserIndexer.java:243)
at com.atlassian.jira.bc.user.search.DirectoryUserIndexer.search(DirectoryUserIndexer.java:228)
Cause
Jira maintains an index of directories, users, groups, and group memberships to expedite searches. Unlike the search index, this index is built at startup and whenever significant directory-related changes are performed. This index does not survive restarts.
You can witness this index being built at startup with this line:
2024-04-19 14:00:00,000-0000 main INFO [c.a.j.c.embedded.ofbiz.IndexedUserDao] Reindex all users took: 80.00 ms
If another environmental issue breaks this index, components that query users will throw "Searcher not available at this moment
" exceptions.
Root Cause 1
The database or file system was previously inaccessible. Root cause analysis requires reviewing application logs to identify the underlying problem.
Root Cause 2
Jira's search index was missing or invalid during startup. This prevented some core services, including the user index, from initializing.
Solution
Solution 1
Once any root cause errors have been addressed, you must force Jira to rebuild the user index.
Completely restarting the application will reset and rebuild the index. On a Data Center cluster, a rolling restart is sufficient.
Solution 2
Please hard reset the cache using the REST API call. Please note that this should not be used in a production environment, as it can impact users as they are working.
Go to
<BASE_URL>/secure/admin/SiteDarkFeatures!default.jspa
Enable dark feature:
com.atlassian.jira.cacheResource.enabled
Trigger this REST endpoint:
DELETE <BASE_URL>/rest/internal/1.0/cache/app
Try to reproduce the issue and check whether the issue is fixed or not.
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