JIRA Notifications Fail Occasionally Due to '452 Too many recipients received this hour'

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptom

Occasionally, notification emails fail with a "Too many recipients" exception:

1 2 3 4 com.atlassian.mail.MailException: javax.mail.SendFailedException: Invalid Addresses; nested exception is: class com.sun.mail.smtp.SMTPAddressFailedException: 452 Too many recipients received this hour at com.atlassian.mail.server.impl.SMTPMailServerImpl.send(SMTPMailServerImpl.java:191) ...

Causes

The return code "452" is coming from SMTP server instead of either JIRA application or Java Mail. Normally, "SMTPAddressFailedException: 452 Too many recipients received this hour" is thrown when breaching the anti-spam restriction of SMTP server regarding the maximum number of recipients that can be sent (from the SMTP server) for a specific domain in a defined time period.

Normally, customers run into this problem because JIRA isn't in a trusted domain of mail server, so the mails coming from there have to go through security gateway and pass the anti-spam check.

Diagnosis

Enable mail protocol logging to find out the route of mail transmission.

Resolution

Configure the trusted domain of mail server to accept requests from the JIRA server. JIRA notification mails should access the SMTP server directly, without an anti-spam check.

Updated on April 7, 2025

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