Jira notification emails contain HTML tags

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

The Jira notification (batched/non-batched) emails received upon a change made to a text field or comment do not render properly: they are plain text emails containing raw HTML source (HTML tags):

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Environment

Any Jira version from 7.x.

Diagnosis

  • The 3rd party add-on JEditor - Rich Text Editor for Jira is installed in the Jira application, which can be verified in the application.xml file from the support zip:

    1 2 3 4 5 6 7 8 9 10 <plugin> <key>com.jiraeditor.jeditor</key> <name>JEditor</name> <version>3.9.9</version> <vendor>Bobronix</vendor> <status>ENABLED</status> <vendor-url>https://bobronix.com</vendor-url> <framework-version>2</framework-version> <bundled>User installed</bundled> </plugin>
  • The problematic text field(s) (or comment field) is configured with a renderer coming from this add-on

    • This can be verified by checking the Field Configuration scheme associated to the project the issue belongs to (in the page ⚙ > Issue > Field Configurations):

      (Auto-migrated image: description temporarily unavailable)
    • This can also be verified by looking at the options available when editing the text field:

      • When using a default renderer coming from Jira out-of-the-box, the panel should look like this:

        (Auto-migrated image: description temporarily unavailable)
      • When using the JEditor rendered, the panel should look like this:

        (Auto-migrated image: description temporarily unavailable)

Cause

The native Jira Notifications templates don't support Jira text field that contain HTML tags and that are using a renderer which is not shipped with Jira. The Jira notification templates only support the plain text format, or the Wiki Renderer format which can then be converted into HTML when the notification email is generated. When using HTML tags in a text field, the Jira Notifications will simply render the HTML tags in plain text, as it does not "know" how to process them.

Solution

2 possible solutions:

  • Suggestion 1

    • Change the field configuration so that it uses Jira's native Wiki Renderer

  • Suggestion 2

Updated on April 8, 2025

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