Jira Mail Handler: Intermittent Email Processing Issues
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Summary
Jira Service Management or Jira Core mail handler occasionally fails to process incoming emails or processes them in the incorrect project.
Diagnosis
There are no processing errors observed in the log file for incoming mail or, for JSM mail handlers, under the Project Settings > Email requests > three dots (•••) > View log > Processing log tab.
There are no discernible patterns: sometimes, emails from the same sender are processed, and other times, they are not.
The emails appear as READ in the mailbox.
Upon checking the configured mail handlers in the affected instance, it's possible to notice that there is more than one mail handler pulling emails from the same mailbox:
Cog icon > System > Incoming Mail (for Jira Core mail handlers).
Cog icon > Applications > Jira Service Management - Email requests (for JSM mail handlers).
Alternatively, there may be another Jira instance (e.g. UAT) that has mail handlers using the same mailbox.
Cause
Multiple mail handlers have been setup to retrieve emails from the same mailbox. You might configure multiple Jira Core mail handlers or a combination of Jira Core and JSM mail handlers in different projects within the same instance or across different Jira instances, such as UAT and Production.
Solution
To manage email retrieval effectively, ensure you have only one active mail handler configured for your mailbox. If you have multiple, decide which one to keep and remove the others to prevent conflicts.
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