Jira mail handler is randomly not processing incoming emails or it processes them in the wrong project

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Summary

Jira Service Management or Jira Core mail handler occasionally fails to process incoming emails or processes them in the incorrect project.

Environment

Any version of Jira or Jira Service Management.

Diagnosis

There are no processing errors observed in the log file for incoming mail or, for JSM mail handlers, under the Project Settings > Email requests > three dots (···) > View log > Processing log tab.

There are no discernible patterns: sometimes the emails from the same sender are processed and other times they are not.

The emails appear as READ in the mailbox.

Upon checking the configured mail handlers in the affected instance, we notice that there is more than one mail handler pulling emails from the same mailbox:

  • ⚙ > System > Incoming Mail (for Jira Core mail handlers)

  • ⚙> Applications > Jira Service Management - Email requests (for JSM mail handlers)

Alternatively, there may be another Jira instance (e.g. UAT) that has mail handlers using the same mailbox.

Cause

Multiple mail handlers have been set up to retrieve emails from the same mailbox. You may have either multiple Jira Core mail handlers or one Jira Core Mail handler and one JSM mail handler configured in different projects within the same instance or across different Jira instances (e.g., UAT and Production).

Solution

Only keep one mail handler that can retrieve emails from the mailbox and remove the unwanted ones.

Updated on March 11, 2025

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