Jira license fails to update, stalls with message 'Updating license key'

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When attempting to install or update a Jira Software or Service Management license, it can stall with the message 'Updating license key', and the progress bar spins from side to side as shown in the screenshot:

(Auto-migrated image: description temporarily unavailable)

Environment

Any Jira version.

Cause

The HTTP POST request to the URL /rest/plugins/applications/1.0/installed/jira-software/license, made in order to update the license, is being blocked by a reverse proxy, firewall, or other network equipment.

Notes: There are other reasons like third party plugins preventing license update on Jira. Please refer the KB article Cannot apply license to Jira Data Center that explains this scenario and workaround steps.

Solution

Ensure HTTP POST requests to the endpoint /rest/plugins/applications/1.0/installed/jira-software/license are not being blocked.

ℹ️ It is also possible to use the private REST API endpoint to update the license:

How to retrieve application license details or set the license via private REST API in Jira 7+

Updated on April 8, 2025

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