Jira issue history tab is not showing change for some fields

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Summary

When viewing Jira's issue history tab, the history of certain fields is omitted.

For example:

  • You can see that the Sprint field for an issue has been defined as "Sprint 1"

  • When checking the issue history tab, there is no indication of when this value had been set to "Sprint 1"

Solution

Environment

Jira Server/Data Center on any version from 7.0.0.

Likely causes

Root Cause 1: Manual database edits

It is possible to adjust and remove issue history by manually editing the SQL database. In those cases, the issue history events are also removed from the Jira issue history tab.

If the history has been removed from the database:

  • The only method to recover this history would be from a backup before the change was made

  • Restoring this backup would also mean losing data between the time of backup and the current time

Root Cause 2: Third-party app interference

A third-party app is blocking the issue history from being displayed, for example: Field Security Plugin for Jira

ℹ️ Note that another side effect of using the add-on Field Security Plugin for Jira is the fact that automation rules using the Field Value Changed trigger might not be triggered as expected, as explained in the KB article Automation For Jira - Some automation rules using the "Field value changed" trigger are not triggered.

If the history is being blocked by a third-party add-on:

  • Determine why the add-on is blocking your fields and reconfigure it properly

  • Or, disable/remove the add-on

ℹ️ In the case of the add-on Field Security Plugin for Jira, disabling this plugin will require a restart of Jira to observe the changes.

Updated on April 2, 2025

Still need help?

The Atlassian Community is here for you.