Jira isn't loading in the browser when started

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Problem

Jira 8.20.25 and later isn’t loading in the browser after you start it. Instead, it’s showing a blank screen.

Cause

This issue is caused by the incompatibility between the Apache Tomcat version and the New Relic agent version that your Jira is using.

Jira 8.20 to 9.3 uses Apache Tomcat 8.5.87. In Jira 9.4, we’ve upgraded Apache Tomcat to 9.0.75. Apache Tomcat 8.5.87 and 9.0.75 are compatible with the New Relic agent 8.2.0 but not with any of its earlier versions. Learn more in the New Relic agent release notes

If your Jira is using any older New Relic agent than 8.2.0, your instance might get broken, preventing Jira to load after the startup.

Solution

To fix the issue, upgrade the New Relic agent to version 8.2.0. Although the New Relic agent is a third-party solution, you can safely check the updates yourself and install it on your instance.

To track the compatibility between Jira and the New Relic agent, follow the document Bundled Tomcat and Java versions.

Updated on April 8, 2025

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