Jira is sending email to inactive users / accounts
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Jira is sending email to inactive users / accounts
Environment
Jira Server / Data Center
Cause
Cause 1:
Inactive Users still receive email notifications from JIRA, even if they continue to remain the assignee, reporter, or watchers of issues.
The behavior is outlined in the BUG: JRASERVER-30152 - Inactive users still receiving emails from "Send email" function
Cause 2:
After deleting a filter from JIRA which had subscriptions prior to deletion, users continue to receive email notifications.
Cause 3:
3rd party plugin, such as ScriptRunner. The e-mail could be sent by a ScriptRunner script triggered by a custom listener. Due to this, the notification is NOT sent by a default notification in Jira, but sent by ScriptRunner.
Cause 4:
Another Jira instance sending emails to these users. ( Testing / Staging Environment )
Solution
Solution for cause 1:
Remove user from all groups. This would prevent JIRA from sending emails to this user when sending email to a group.
Solution for cause 2:
Run a SQL Query to delete the filter. The solution is outlined in this article: Keep receiving subscription emails from deleted filter
Solution for cause 3:
Check if the ScriptRunner script is fetching all users, including the inactive users, if it's the case, FIX the ScriptRunner script to check if the user is inactive.
Disable the ScriptRunner plugin to test if it's this plugin related.
Enable Safe Mode to test if it's any other plugin related.
Solution for cause 4:
Perform the same resolution above for the other Jira instance.
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