Jira is not capturing all emails
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Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Problem
Jira is not retrieving all emails that a user sends.
After sending many emails to Jira or Jira Service Management, only a few mails are added to the issue as comments.
Diagnosis
Although Jira is properly configured and
is able to retrieve emails from the configured mailbox
Replying to an issue by email adds the comment on the Jira issue
When sending multiple emails at once, it fails to do so.
Cause
Jira Incoming Mail configuration "Messages Threshold" is set to a low value and Jira mail handler considers emails as 'Bulk'.
Solution
Resolution
On the "Incoming Mail" section (under System Administration) set the "Messages Threshold" to a higher value or set "Whitelisted Domains" to prevent it from happening to known email addresses.
The "Messages Threshold" can also be disabled by setting it to 0 but the previous options are recommended.
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