JIRA Has Been Locked: No enum constant com.atlassian.crowd.model.membership.MembershipType.GROUP USER

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

When trying to start JIRA, the homepage in the browser reports that JIRA has been locked.

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The following appears in the atlassian-jira.log:

1 No enum constant com.atlassian.crowd.model.membership.MembershipType.GROUP USER

Diagnosis

To diagnose if this is the issue affecting your JIRA, run the following query against your database:

1 SELECT DISTINCT membership_type FROM cwd_membership WHERE membership_type LIKE '% %';

This command must return an empty set. Substitute an underscore for a space in every membership_type returned.

Cause

This is caused by the use of an enumerator to store the membership values; the space is an invalid character in that position.

Resolution

Always back up your data before making any database modifications. If possible, test any alter, insert, update, or delete SQL commands on a staging server first.

  • Substitute an underscore for a space in every membership_type returned in the previous query.

Updated on April 8, 2025

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