JIRA fires Issue Assigned event for newly created issues
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*Except Fisheye and Crucible
Summary
Problem
When a new issue is created, the Issue Assigned event is fired instead of the Issue Created event. The newly created issue is automatically assigned to someone
This can be identified by
Modifying the Subject templates to include $eventTypeName and checking the Mail Queue immediately after creating the issue. Example:
1 2
#disable_html_escaping ($issue.key) $eventTypeName: $issue.summary
Wait and receive the mail notification for Issue Assigned
Diagnosis
Workflow
The post function for the Create transition is firing the Issue Created event
Notification Scheme
For the affected project' Notification Scheme
The Issue Created event does not send notification to the the assigned user
The Issue Assigned event sends a notification to the assigned user
Default Assignee
The project is configured to have a default assignee to either Project Lead, Component Lead or any specific users
Cause
The cause of the problem is the combination of Notification Scheme and Default Assignee of the project as stated in the Diagnosis section above
When the issue is created, it will automatically be assigned to a user due to it's Default Assignee option. This will mean that there are 2 events here (Issue Created & Issue Assigned)
If Issue Created and Issue Assigned is configured to send notification to the user, then the user will only receive one notification, that of Issue Created, since this happens "simultaneously". This is so duplicate notifications for the same event (Create + Assign) isn't sent
Since Issue Created does not send notification to the user, the user will still receive the notifications of Issue Assigned, hence causing the confusion
With the configuration configured as per the Diagnosis section, every newly created issue will be assigned to a user, and the user will receive notification for Issue Assigned since the user isn't configured to receive Issue Created
Solution
Resolution
This is expected behaviour of the current configurations of Notification Scheme and Default Assignee. If you want the user to receive the Issue Created instead, then make sure to configure this in the Notification Scheme
Diagnostic Steps
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