JIRA fires Issue Assigned event for newly created issues

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*Except Fisheye and Crucible

Summary

Problem

When a new issue is created, the Issue Assigned event is fired instead of the Issue Created event. The newly created issue is automatically assigned to someone

This can be identified by

  1. Modifying the Subject templates to include $eventTypeName and checking the Mail Queue immediately after creating the issue. Example:

    #disable_html_escaping ($issue.key) $eventTypeName: $issue.summary
  2. Wait and receive the mail notification for Issue Assigned

Diagnosis

Workflow

  • The post function for the Create transition fires the Issue Created event.

Notification Scheme

For the affected project' Notification Scheme:

  • The Issue Created event does not send a notification to the assigned user.

  • The Issue Assigned event sends a notification to the assigned user.

Default Assignee

  • The project is configured to have a default assignee to either the Project Lead, the Component Lead, or any specific users.

Cause

The problem is caused by the combination of the project's Notification Scheme and Default Assignee, as stated in the Diagnosis section above.

  1. When an issue is created, it will automatically be assigned to a user due to its Default Assignee option. This means that there are 2 events here (Issue Created & Issue Assigned).

  2. If Issue Created and Issue Assigned are configured to send notifications to the user, then the user will only receive one notification, that of Issue Created, since this happens "simultaneously". This is so duplicate notifications for the same event (Create + Assign) aren't sent.

  3. Since Issue Created does not send a notification to the user, the user will still receive the notifications of Issue Assigned, hence causing the confusion

  4. With the configuration configured as per the Diagnosis section, every newly created issue will be assigned to a user, and the user will receive a notification for Issue Assigned since the user isn't configured to receive Issue Created.

Solution

Resolution

This is expected behaviour of the current configurations of the Notification Scheme and the Default Assignee. If you want the user to receive the Issue Created instead, then make sure to configure this in the Notification Scheme.

Updated on September 26, 2025

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