Jira Fields unavailable when using Jira Importers Plugin(JIM)
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Symptoms
A field is unavailable under the options for field mapping. For example, the JIRA field Assignee is missing in the JIRA Field dropdown.

Environment
Jira Data Center on any version from 8.0.0.
Cause
The user uploading the csv file doesn't have the correct permissions to edit the field.


Resolution
Check that the user in question has the correct project role permissions to perform the task associated with the field they're importing.
ex. "Assign Issues" Permission and the assignee field
Was this helpful?