JIRA fails to assign to CC field user
Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.
Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.
*Except Fisheye and Crucible
Summary
Symptoms
Using a mail handler set up to Auto Assign to CC, one or more users do not get assigned when an Issue is created with them in CC field.
Diagnosis
This issue does not report in the logs. To diagnose this issue, find a user that has the problem, and use the User Browser to search for users with an identical e-mail address.
Cause
When two users share the same email address but only one of them can be the assignee for the Issue, JIRA is not able to determine the correct assignee.
Solution
Workaround
Ensure that there are no two users that share the same email address.
Resolution
This Issue is being tracked as JRASERVER-31464 - When ccassignee is not an Assignable user, no error is logged
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