JIRA email template variable not replaced in the email received

Platform Notice: Data Center Only - This article only applies to Atlassian products on the Data Center platform.

Note that this KB was created for the Data Center version of the product. Data Center KBs for non-Data-Center-specific features may also work for Server versions of the product, however they have not been tested. Support for Server* products ended on February 15th 2024. If you are running a Server product, you can visit the Atlassian Server end of support announcement to review your migration options.

*Except Fisheye and Crucible

Symptoms

The same problem could occur with JIRA Servicedesk emails as well.

The email from JIRA are received something like this :

1 Status changed to Fixed with resolution {1}

It should be :

1 Status changed to Fixed with resolution Answered

The variables from the email template are not replaced by the actual values.

Cause

There is a post-function(might be coming from a plugin) in the workflow that is sending the email. This post-function is delaying the transition for so long that the email is sent before it is completely rendered.

Workaround

Remove the post-function.

Resolution

  • Check where the post-function is coming from and report a bug to the respective vendor.

Updated on April 8, 2025

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